Jump to content

You're currently viewing the forum as a Guest
register-now-button_orig.png
and join in with discussions   
ask migration questions
message other members

..and much much more!

Millie

Processing time for the Partner Visa (subclass 309)?

Recommended Posts

I know their website says 13-19 months but I know a lot of people say they're not accurate. I don't want to have to wait that long if it is the case because I won't be able to see my partner. I tried looking at the visitor visa so that I could apply onshore but it looks like that visa has a no further stay condition. How long does the Partner Visa take to be granted offshore and are there any other options so that I can apply onshore?

Share this post


Link to post
Share on other sites

Hi millie. I applied offshore in uk. Applied on 17th may and got it approved 3rd july! Obviously everyone will be different and take longer but from what i have seen it takes a lot shorter. Any other qs feel free to ask :)

????

Share this post


Link to post
Share on other sites
1 minute ago, nava24 said:

Hi millie. I applied offshore in uk. Applied on 17th may and got it approved 3rd july! Obviously everyone will be different and take longer but from what i have seen it takes a lot shorter. Any other qs feel free to ask :)

????
 

It took less than 2 months?! Wow! What was the process like and did you have any problems? Thanks a lot!

Share this post


Link to post
Share on other sites

No worries :) yeah we were shocked at how quick it was approved. No issues at all. Was contacted by a case officer not long after asking more info & bobs your uncle it was approved. I think its just evidence and things they need to see it is genuine

????

Share this post


Link to post
Share on other sites

Hi! My application was sent on 28/6/17, got a standard auto reply on 29th saying it has been received. Heard nothing since :-( 309/100 offshore

Sent from my Archos 50 Power using PomsinOz mobile app

  • Like 1

Share this post


Link to post
Share on other sites
Hi! My application was sent on 28/6/17, got a standard auto reply on 29th saying it has been received. Heard nothing since :-( 309/100 offshore

Sent from my Archos 50 Power using PomsinOz mobile app






It took less than 2 months?! Wow! What was the process like and did you have any problems? Thanks a lot!

They may have had a massive influx of applications. Hang in there!!

????

  • Like 1

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×